Discussion:
Incompatible library version for module
(too old to reply)
Jarek Jasiewicz
2009-01-02 14:31:31 UTC
Permalink
In fact I didn't use R for two month so maybe I lost something but
after compilation of grass 6.4 svn I tiried to read raster I recive the
library(spgrass6)
Loading required package: sp
Loading required package: rgdal
Geospatial Data Abstraction Library extensions to R successfully loaded
Loaded GDAL runtime: GDAL 1.5.3, released 2008/09/09
GDAL_DATA: /usr/local/lib/R/site-library/rgdal/gdal
Loaded PROJ.4 runtime: Rel. 4.6.1, 21 August 2008
PROJ_LIB: /usr/local/lib/R/site-library/rgdal/proj
GRASS GIS interface loaded with GRASS version: 6.4.svn
and location: Polska
r=readRAST6("Polska")
B??D:Incompatible library version for module
[Raster MASK present]
GRASS 6.4.svn (Polska):~ >

Finally R crashed.

importing with plugin=FALSE goes OK

I heave similar problem (and the same message) with qgis (problem is
confirmed on qgis list).

I recompiled gdal and spgrass in my R environment but it looks the
problem is from within GRASS-GDAL (sam message on R and QGIS)

Jarek

BTW:
Ubuntu Hardy
GDAL, PROJ as above,
GRASS svn from 30.12.2008
spgrass and rgdal just downloaded and recompiled
Markus Neteler
2009-01-02 17:03:34 UTC
Permalink
In fact I didn't use R for two month so maybe I lost something but after
compilation of grass 6.4 svn I tiried to read raster I recive the
I assume that you did not run
make distclean
to compile GRASS (see below).
library(spgrass6)
Loading required package: sp
Loading required package: rgdal
Geospatial Data Abstraction Library extensions to R successfully loaded
Loaded GDAL runtime: GDAL 1.5.3, released 2008/09/09
GDAL_DATA: /usr/local/lib/R/site-library/rgdal/gdal
Loaded PROJ.4 runtime: Rel. 4.6.1, 21 August 2008
PROJ_LIB: /usr/local/lib/R/site-library/rgdal/proj
GRASS GIS interface loaded with GRASS version: 6.4.svn
and location: Polska
r=readRAST6("Polska")
B??D:Incompatible library version for module
If this occurs, a full GRASS recompile is needed. Official answer
from Glynn:


On Mon, Sep 8, 2008 at 11:10 PM, Glynn Clements
The error could also be caused by a mismatch between PATH and
LD_LIBRARY_PATH (or ld.so.cache, etc) if you have more than one
version of GRASS installed.
Or it could be caused by a module linking against GDAL, where GDAL was
built against an old version of GRASS. In that case, it's true that
recompilation is needed, but it would be GDAL that needs
recompilation.
But typically a GRASS recompilation suffices when this message appears.

Markus
Jarek Jasiewicz
2009-01-02 19:39:01 UTC
Permalink
Post by Markus Neteler
In fact I didn't use R for two month so maybe I lost something but after
compilation of grass 6.4 svn I tiried to read raster I recive the
I assume that you did not run
make distclean
to compile GRASS (see below).
Thanks for ansver but unfortunately I always do makedistclean in grass
before compilation

addationaly I simply did:

gdalinfo /home/jarekj/grassdata/Polska/PERMANENT/cellhd/Polska
ERROR:Incompatible library version for module

Here is the problem

so not the GRASS but grass-gdal plugin must to be recompiled. I think it
is not intended because plugin was created for to not compile gdal
everytime grass has ben recompiled

I ecompiled plugin, it and everthing is OK




But the issue with plugin which emerged is as follows:

r=readRAST6("Polska", plugin=FALSE)

Exporting raster as integer values (bytes=2)
Using the current region settings...
north=804414.520000
south=137864.430000
east=865559.620000
west=180375.670000
r=1333
c=1370
100%


It is OK, my region settings are included

ra=readRAST6("Polska", plugin=TRUE)
/home/data/grassdata/Polska/PERMANENT/cellhd/Polska has GDAL driver GRASS
and has 21601 rows and 18001 columns

it is also OK because original map is rather big

next were eror due to file size

but this means that plugin ignores current region setings!
Jarek





_

_
Markus Neteler
2009-01-03 07:54:09 UTC
Permalink
Post by Jarek Jasiewicz
Post by Markus Neteler
In fact I didn't use R for two month so maybe I lost something but after
compilation of grass 6.4 svn I tiried to read raster I recive the
I assume that you did not run
make distclean
to compile GRASS (see below).
Thanks for ansver but unfortunately I always do makedistclean in grass
before compilation
gdalinfo /home/jarekj/grassdata/Polska/PERMANENT/cellhd/Polska
ERROR:Incompatible library version for module
Here is the problem
so not the GRASS but grass-gdal plugin must to be recompiled. I think it is
not intended because plugin was created for to not compile gdal everytime
grass has ben recompiled
I ecompiled plugin, it and everthing is OK
Good to know that. Perhaps report this to the plugin author (GDAL team)
if it is really a problem. I never had it.
Post by Jarek Jasiewicz
r=readRAST6("Polska", plugin=FALSE)
Exporting raster as integer values (bytes=2)
[This msg indicates that the old mechanism of the R extension
is used.]
Post by Jarek Jasiewicz
Using the current region settings...
north=804414.520000
south=137864.430000
east=865559.620000
west=180375.670000
r=1333
c=1370
100%
It is OK, my region settings are included
ra=readRAST6("Polska", plugin=TRUE)
/home/data/grassdata/Polska/PERMANENT/cellhd/Polska has GDAL driver GRASS
and has 21601 rows and 18001 columns
it is also OK because original map is rather big
next were eror due to file size
but this means that plugin ignores current region setings!
Yes. That's why I suggested to implement r.out.gdal usage
in the GRASS-R extension time ago (see this list archive,
date Sun, Jun 1, 2008 at 9:40 PM
subject Re: [GRASS-stats] Speedup of readVECT6() with plugin
).

There is a "plugin" switch which you set to plugin=TRUE, perhaps
it needs to be FALSE to make use of the better + faster r.out.gdal
which would solve your problem as it is resolution/region sensitive.

I didn't try the GRASS-R extension for a while. Definitely you need
a fresh version of the GRASS-R extension.

Markus
Markus Neteler
2009-01-03 10:01:03 UTC
Permalink
Post by Markus Neteler
Post by Jarek Jasiewicz
but this means that plugin ignores current region setings!
Yes. That's why I suggested to implement r.out.gdal usage
in the GRASS-R extension time ago (see this list archive,
date Sun, Jun 1, 2008 at 9:40 PM
subject Re: [GRASS-stats] Speedup of readVECT6() with plugin
).
There is a "plugin" switch which you set to plugin=TRUE, perhaps
it needs to be FALSE to make use of the better + faster r.out.gdal
which would solve your problem as it is resolution/region sensitive.
OK, I checked the source code of spgrass6_0.5-16.tar.gz
and the manual at
http://cran.r-project.org/web/packages/spgrass6/index.html

which says:
"useGDAL:
default FALSE using r.out.bin or r.in.bin, if TRUE use r.out.gdal
or r.in.gdal,
GTiff, and readGDAL or writeGDAL
"

So this switch should solve your problem.

Markus

PS: Upon a test if GRASS is >= 6.4 I suggest to set useGDAL=TRUE
in spgrass6.
Roger Bivand
2009-01-03 11:10:35 UTC
Permalink
Post by Markus Neteler
Post by Jarek Jasiewicz
Post by Markus Neteler
In fact I didn't use R for two month so maybe I lost something but after
compilation of grass 6.4 svn I tiried to read raster I recive the
I assume that you did not run
make distclean
to compile GRASS (see below).
Thanks for ansver but unfortunately I always do makedistclean in grass
before compilation
gdalinfo /home/jarekj/grassdata/Polska/PERMANENT/cellhd/Polska
ERROR:Incompatible library version for module
Here is the problem
so not the GRASS but grass-gdal plugin must to be recompiled. I think it is
not intended because plugin was created for to not compile gdal everytime
grass has ben recompiled
I ecompiled plugin, it and everthing is OK
Good to know that. Perhaps report this to the plugin author (GDAL team)
if it is really a problem. I never had it.
Post by Jarek Jasiewicz
r=readRAST6("Polska", plugin=FALSE)
Exporting raster as integer values (bytes=2)
[This msg indicates that the old mechanism of the R extension
is used.]
Post by Jarek Jasiewicz
Using the current region settings...
north=804414.520000
south=137864.430000
east=865559.620000
west=180375.670000
r=1333
c=1370
100%
It is OK, my region settings are included
ra=readRAST6("Polska", plugin=TRUE)
/home/data/grassdata/Polska/PERMANENT/cellhd/Polska has GDAL driver GRASS
and has 21601 rows and 18001 columns
it is also OK because original map is rather big
next were eror due to file size
but this means that plugin ignores current region setings!
Yes. That's why I suggested to implement r.out.gdal usage
in the GRASS-R extension time ago (see this list archive,
date Sun, Jun 1, 2008 at 9:40 PM
subject Re: [GRASS-stats] Speedup of readVECT6() with plugin
).
There is a "plugin" switch which you set to plugin=TRUE, perhaps
it needs to be FALSE to make use of the better + faster r.out.gdal
which would solve your problem as it is resolution/region sensitive.
I didn't try the GRASS-R extension for a while. Definitely you need
a fresh version of the GRASS-R extension.
The current settings of readRAST6() will use the plugin if available (but
try to check that the regions match) when plugin=NULL. If you want to
force the use of r.out.gdal, set plugin=FALSE and useGDAL=TRUE (version
0.5-16). Please let me know if this helps.

Roger
Post by Markus Neteler
Markus
_______________________________________________
grass-stats mailing list
http://lists.osgeo.org/mailman/listinfo/grass-stats
--
Roger Bivand
Economic Geography Section, Department of Economics, Norwegian School of
Economics and Business Administration, Helleveien 30, N-5045 Bergen,
Norway. voice: +47 55 95 93 55; fax +47 55 95 95 43
e-mail: ***@nhh.no
Markus Neteler
2009-01-10 14:20:16 UTC
Permalink
Post by Roger Bivand
The current settings of readRAST6() will use the plugin if available (but
try to check that the regions match) when plugin=NULL. If you want to force
the use of r.out.gdal, set plugin=FALSE and useGDAL=TRUE (version 0.5-16).
Please let me know if this helps.
I have installed R (R version 2.8.1 (2008-12-22)) + extensions from scratch.
Post by Roger Bivand
elev <- readRAST6("elev_state_500m", mapset="PERMANENT", ignore.stderr=TRUE)
cols rows origin.northing origin.easting
FALSE FALSE FALSE TRUE
Warning message:
In readRAST6("elev_state_500m", mapset = "PERMANENT", :
set plugin=FALSE - raster/current window mismatch
or plugin=TRUE to override; continuing with plugin=FALSE

To me it is not clear from the message that I should (better) set
useGDAL=TRUE

Ideally, the interface would work as simple as this
elev <- readRAST6("elev_state_500m")

which would
* find the map in the current mapset search path (internally, use g.findfile),
in my tests I was in a mapset different from PERMANENT which leads to
elev <- readRAST6("elev_state_500m", ignore.stderr=TRUE)
Error in .local(.Object, ...) :
GDAL Error 4:
`/home/neteler/grassdata/nc_spm_07/user1/cellhd/elev_state_500m' does
not exist in the file system,
and is not recognised as a supported dataset name.

* use the current region (internally, use r.in.gdal and not the plugin
if GRASS >= 6.4)

Successfully, I have used today:
elev <- readRAST6("elev_state_500m", mapset="PERMANENT",
ignore.stderr=TRUE, plugin=FALSE, useGDAL=TRUE)

which is rather long/complex.

Hope I am not asking too much - try to compensate with GRASS 6.4.x work :)

Markus
Roger Bivand
2009-01-10 21:20:56 UTC
Permalink
Post by Markus Neteler
Post by Roger Bivand
The current settings of readRAST6() will use the plugin if available (but
try to check that the regions match) when plugin=NULL. If you want to force
the use of r.out.gdal, set plugin=FALSE and useGDAL=TRUE (version 0.5-16).
Please let me know if this helps.
I have installed R (R version 2.8.1 (2008-12-22)) + extensions from scratch.
Post by Roger Bivand
elev <- readRAST6("elev_state_500m", mapset="PERMANENT", ignore.stderr=TRUE)
cols rows origin.northing origin.easting
FALSE FALSE FALSE TRUE
set plugin=FALSE - raster/current window mismatch
or plugin=TRUE to override; continuing with plugin=FALSE
To me it is not clear from the message that I should (better) set
useGDAL=TRUE
Ideally, the interface would work as simple as this
elev <- readRAST6("elev_state_500m")
which would
* find the map in the current mapset search path (internally, use g.findfile),
in my tests I was in a mapset different from PERMANENT which leads to
elev <- readRAST6("elev_state_500m", ignore.stderr=TRUE)
`/home/neteler/grassdata/nc_spm_07/user1/cellhd/elev_state_500m' does
not exist in the file system,
and is not recognised as a supported dataset name.
* use the current region (internally, use r.in.gdal and not the plugin
if GRASS >= 6.4)
Markus,
Post by Markus Neteler
library(spgrass6)
Loading required package: sp
Loading required package: rgdal
Geospatial Data Abstraction Library extensions to R successfully loaded
Loaded GDAL runtime: GDAL 1.6.0, released 2008/12/04
GDAL_DATA: /home/rsb/lib/r_libs/rgdal/gdal
Loaded PROJ.4 runtime: Rel. 4.6.1, 21 August 2008
PROJ_LIB: /home/rsb/lib/r_libs/rgdal/proj
GRASS GIS interface loaded with GRASS version: 6.4.0RC1
and location: nc_spm_08
Post by Markus Neteler
elev <- readRAST6("elev_state_500m")
cols rows origin.northing origin.easting
FALSE FALSE FALSE FALSE
ERROR 6: SetColorTable() only supported for Byte or UInt16 bands in TIFF
format.
WARNING: Input raster map contains cells with NULL-value (no-data). The
value 999 was used to represent no-data values in the input map.
You can specify nodata value by nodata parameter.
/home/rsb/topics/grassdata/nc_spm_08/rsb/.tmp/reclus2/elev_state_500m has
GDAL driver GTiff
and has 620 rows and 1630 columns
Warning message:
In readRAST6("elev_state_500m") :
set plugin=FALSE - raster/current window mismatch
or plugin=TRUE to override; continuing with plugin=FALSE

which I agree is unhelpful (and most of it cannot be avoided on Windows,
where stderr cannot be ignored). I can work on some of this, but the two
r.out.gdal messages are not on my side. Even if I set GRASS_VERBOSE to 0,
won't they still be displayed?

Roger
Post by Markus Neteler
elev <- readRAST6("elev_state_500m", mapset="PERMANENT",
ignore.stderr=TRUE, plugin=FALSE, useGDAL=TRUE)
which is rather long/complex.
Hope I am not asking too much - try to compensate with GRASS 6.4.x work :)
Markus
--
Roger Bivand
Economic Geography Section, Department of Economics, Norwegian School of
Economics and Business Administration, Helleveien 30, N-5045 Bergen,
Norway. voice: +47 55 95 93 55; fax +47 55 95 95 43
e-mail: ***@nhh.no
Markus Neteler
2009-01-10 22:47:37 UTC
Permalink
Roger,
Post by Roger Bivand
Post by Markus Neteler
Post by Roger Bivand
The current settings of readRAST6() will use the plugin if available (but
try to check that the regions match) when plugin=NULL. If you want to force
the use of r.out.gdal, set plugin=FALSE and useGDAL=TRUE (version 0.5-16).
Please let me know if this helps.
I have installed R (R version 2.8.1 (2008-12-22)) + extensions from scratch.
Post by Roger Bivand
elev <- readRAST6("elev_state_500m", mapset="PERMANENT",
ignore.stderr=TRUE)
cols rows origin.northing origin.easting
FALSE FALSE FALSE TRUE
set plugin=FALSE - raster/current window mismatch
or plugin=TRUE to override; continuing with plugin=FALSE
To me it is not clear from the message that I should (better) set
useGDAL=TRUE
Ideally, the interface would work as simple as this
elev <- readRAST6("elev_state_500m")
which would
* find the map in the current mapset search path (internally, use g.findfile),
in my tests I was in a mapset different from PERMANENT which leads to
elev <- readRAST6("elev_state_500m", ignore.stderr=TRUE)
`/home/neteler/grassdata/nc_spm_07/user1/cellhd/elev_state_500m' does
not exist in the file system,
and is not recognised as a supported dataset name.
* use the current region (internally, use r.in.gdal and not the plugin
if GRASS >= 6.4)
Markus,
Post by Markus Neteler
library(spgrass6)
Loading required package: sp
Loading required package: rgdal
Geospatial Data Abstraction Library extensions to R successfully loaded
Loaded GDAL runtime: GDAL 1.6.0, released 2008/12/04
GDAL_DATA: /home/rsb/lib/r_libs/rgdal/gdal
Loaded PROJ.4 runtime: Rel. 4.6.1, 21 August 2008
PROJ_LIB: /home/rsb/lib/r_libs/rgdal/proj
GRASS GIS interface loaded with GRASS version: 6.4.0RC1
and location: nc_spm_08
Post by Markus Neteler
elev <- readRAST6("elev_state_500m")
cols rows origin.northing origin.easting
FALSE FALSE FALSE FALSE
ERROR 6: SetColorTable() only supported for Byte or UInt16 bands in TIFF
format.
This message *is* confusing as it is a warning only. It comes from GDAL:
gdal/frmts/gtiff/geotiff.cpp: "SetColorTable() only
supportedfor Byte or UInt16 bands in TIFF format." );

if( eDataType != GDT_Byte && eDataType != GDT_UInt16 )
{
CPLError( CE_Failure, CPLE_NotSupported,
"SetColorTable() only supported for Byte or UInt16
bands in TIFF format." );
return CE_Failure;
}

I suppose there is some trick to suppress it (since it uses the
CPLError function).
I don't know too much about it but found
http://www.gdal.org/ogr/cpl__error_8h.html#ad2b98dd58e4de706a245faddac90403

Just throw stderr stuff to /dev/null (of course problematic with Windows)?
Post by Roger Bivand
WARNING: Input raster map contains cells with NULL-value (no-data). The
value 999 was used to represent no-data values in the input map.
You can specify nodata value by nodata parameter.
/home/rsb/topics/grassdata/nc_spm_08/rsb/.tmp/reclus2/elev_state_500m has
GDAL driver GTiff
and has 620 rows and 1630 columns
set plugin=FALSE - raster/current window mismatch
or plugin=TRUE to override; continuing with plugin=FALSE
which I agree is unhelpful (and most of it cannot be avoided on Windows,
where stderr cannot be ignored). I can work on some of this, but the two
r.out.gdal messages are not on my side. Even if I set GRASS_VERBOSE to 0,
won't they still be displayed?
It was implemented as G_warning(). In contact with the person who
added this, we have now changed to G_important_message() which
respects GRASS_VERBOSE=0:

http://trac.osgeo.org/grass/changeset/35321

It is in 6.4SVN and 7 SVN and will appear on Monday in 6.4.0RC2.
GRASS 6.3 and older are not affected as r.out.gdal wasn't there.

Thanks,
Markus
Post by Roger Bivand
Roger
Post by Markus Neteler
elev <- readRAST6("elev_state_500m", mapset="PERMANENT",
ignore.stderr=TRUE, plugin=FALSE, useGDAL=TRUE)
which is rather long/complex.
Hope I am not asking too much - try to compensate with GRASS 6.4.x work :)
Markus
--
Roger Bivand
Economic Geography Section, Department of Economics, Norwegian School of
Economics and Business Administration, Helleveien 30, N-5045 Bergen,
Norway. voice: +47 55 95 93 55; fax +47 55 95 95 43
--
Open Source Geospatial Foundation
http://www.osgeo.org/
http://www.grassbook.org/
Roger Bivand
2009-01-11 16:48:32 UTC
Permalink
Post by Markus Neteler
Roger,
Post by Roger Bivand
Post by Markus Neteler
Post by Roger Bivand
The current settings of readRAST6() will use the plugin if available (but
try to check that the regions match) when plugin=NULL. If you want to force
the use of r.out.gdal, set plugin=FALSE and useGDAL=TRUE (version 0.5-16).
Please let me know if this helps.
I have installed R (R version 2.8.1 (2008-12-22)) + extensions from scratch.
Post by Roger Bivand
elev <- readRAST6("elev_state_500m", mapset="PERMANENT",
ignore.stderr=TRUE)
cols rows origin.northing origin.easting
FALSE FALSE FALSE TRUE
set plugin=FALSE - raster/current window mismatch
or plugin=TRUE to override; continuing with plugin=FALSE
To me it is not clear from the message that I should (better) set
useGDAL=TRUE
Ideally, the interface would work as simple as this
elev <- readRAST6("elev_state_500m")
which would
* find the map in the current mapset search path (internally, use g.findfile),
in my tests I was in a mapset different from PERMANENT which leads to
elev <- readRAST6("elev_state_500m", ignore.stderr=TRUE)
`/home/neteler/grassdata/nc_spm_07/user1/cellhd/elev_state_500m' does
not exist in the file system,
and is not recognised as a supported dataset name.
* use the current region (internally, use r.in.gdal and not the plugin
if GRASS >= 6.4)
Markus,
Post by Markus Neteler
library(spgrass6)
Loading required package: sp
Loading required package: rgdal
Geospatial Data Abstraction Library extensions to R successfully loaded
Loaded GDAL runtime: GDAL 1.6.0, released 2008/12/04
GDAL_DATA: /home/rsb/lib/r_libs/rgdal/gdal
Loaded PROJ.4 runtime: Rel. 4.6.1, 21 August 2008
PROJ_LIB: /home/rsb/lib/r_libs/rgdal/proj
GRASS GIS interface loaded with GRASS version: 6.4.0RC1
and location: nc_spm_08
Post by Markus Neteler
elev <- readRAST6("elev_state_500m")
cols rows origin.northing origin.easting
FALSE FALSE FALSE FALSE
ERROR 6: SetColorTable() only supported for Byte or UInt16 bands in TIFF
format.
gdal/frmts/gtiff/geotiff.cpp: "SetColorTable() only
supportedfor Byte or UInt16 bands in TIFF format." );
if( eDataType != GDT_Byte && eDataType != GDT_UInt16 )
{
CPLError( CE_Failure, CPLE_NotSupported,
"SetColorTable() only supported for Byte or UInt16
bands in TIFF format." );
return CE_Failure;
}
I suppose there is some trick to suppress it (since it uses the
CPLError function).
I don't know too much about it but found
http://www.gdal.org/ogr/cpl__error_8h.html#ad2b98dd58e4de706a245faddac90403
Just throw stderr stuff to /dev/null (of course problematic with Windows)?
I've "handled" this for some definition of handle by setting -c in the
r.out.gdal call - this was controlling whether colour table writing was
attempted.
Post by Markus Neteler
Post by Roger Bivand
WARNING: Input raster map contains cells with NULL-value (no-data). The
value 999 was used to represent no-data values in the input map.
You can specify nodata value by nodata parameter.
/home/rsb/topics/grassdata/nc_spm_08/rsb/.tmp/reclus2/elev_state_500m has
GDAL driver GTiff
and has 620 rows and 1630 columns
set plugin=FALSE - raster/current window mismatch
or plugin=TRUE to override; continuing with plugin=FALSE
which I agree is unhelpful (and most of it cannot be avoided on Windows,
where stderr cannot be ignored). I can work on some of this, but the two
r.out.gdal messages are not on my side. Even if I set GRASS_VERBOSE to 0,
won't they still be displayed?
It was implemented as G_warning(). In contact with the person who
added this, we have now changed to G_important_message() which
http://trac.osgeo.org/grass/changeset/35321
It is in 6.4SVN and 7 SVN and will appear on Monday in 6.4.0RC2.
GRASS 6.3 and older are not affected as r.out.gdal wasn't there.
library(spgrass6)
Loading required package: sp
Loading required package: rgdal
Geospatial Data Abstraction Library extensions to R successfully loaded
Loaded GDAL runtime: GDAL 1.6.0, released 2008/12/04
GDAL_DATA: /home/rsb/lib/r_libs/rgdal/gdal
Loaded PROJ.4 runtime: Rel. 4.6.1, 21 August 2008
PROJ_LIB: /home/rsb/lib/r_libs/rgdal/proj
GRASS GIS interface loaded with GRASS version: 6.4.0svn
and location: nc_spm_08
Post by Markus Neteler
elev <- readRAST6("elev_state_500m")
raster/current region mismatch detected in components:
cols rows origin.northing origin.easting
FALSE FALSE FALSE FALSE
set plugin=TRUE to override; continuing with plugin=FALSE
/home/rsb/topics/grassdata/nc_spm_08/rsb/.tmp/reclus2/elev_state_500m has
GDAL driver GTiff
and has 620 rows and 1630 columns
Post by Markus Neteler
elev <- readRAST6("elev_state_500m", ignore.stderr=TRUE)
I've committed to sourceforge CVS, could you confirm that this is OK?

How does one manage the plugin links in a mixed 6.4/7.0 setting? I tried
7.0 first, but I think there was a problem:

ERROR: Incompatible library version for module

which crashed R/rgdal. The plugin was built against 6.4RC1, so probably
two different library versions had a disagreement.

Best wishes,

Roger
Post by Markus Neteler
Thanks,
Markus
Post by Roger Bivand
Roger
Post by Markus Neteler
elev <- readRAST6("elev_state_500m", mapset="PERMANENT",
ignore.stderr=TRUE, plugin=FALSE, useGDAL=TRUE)
which is rather long/complex.
Hope I am not asking too much - try to compensate with GRASS 6.4.x work :)
Markus
--
Roger Bivand
Economic Geography Section, Department of Economics, Norwegian School of
Economics and Business Administration, Helleveien 30, N-5045 Bergen,
Norway. voice: +47 55 95 93 55; fax +47 55 95 95 43
--
Roger Bivand
Economic Geography Section, Department of Economics, Norwegian School of
Economics and Business Administration, Helleveien 30, N-5045 Bergen,
Norway. voice: +47 55 95 93 55; fax +47 55 95 95 43
e-mail: ***@nhh.no
Markus Neteler
2009-01-11 19:09:57 UTC
Permalink
...
Post by Roger Bivand
Post by Markus Neteler
gdal/frmts/gtiff/geotiff.cpp: "SetColorTable() only
supportedfor Byte or UInt16 bands in TIFF format." );
if( eDataType != GDT_Byte && eDataType != GDT_UInt16 )
{
CPLError( CE_Failure, CPLE_NotSupported,
"SetColorTable() only supported for Byte or UInt16
bands in TIFF format." );
return CE_Failure;
}
I suppose there is some trick to suppress it (since it uses the
CPLError function).
I don't know too much about it but found
http://www.gdal.org/ogr/cpl__error_8h.html#ad2b98dd58e4de706a245faddac90403
Just throw stderr stuff to /dev/null (of course problematic with Windows)?
I've "handled" this for some definition of handle by setting -c in the
r.out.gdal call - this was controlling whether colour table writing was
attempted.
ah fine, I didn't think of this possibility.
Post by Roger Bivand
Post by Markus Neteler
Post by Roger Bivand
WARNING: Input raster map contains cells with NULL-value (no-data). The
value 999 was used to represent no-data values in the input map.
You can specify nodata value by nodata parameter.
...
Post by Roger Bivand
Post by Markus Neteler
http://trac.osgeo.org/grass/changeset/35321
It is in 6.4SVN and 7 SVN and will appear on Monday in 6.4.0RC2.
GRASS 6.3 and older are not affected as r.out.gdal wasn't there.
library(spgrass6)
Loading required package: sp
Loading required package: rgdal
Geospatial Data Abstraction Library extensions to R successfully loaded
Loaded GDAL runtime: GDAL 1.6.0, released 2008/12/04
GDAL_DATA: /home/rsb/lib/r_libs/rgdal/gdal
Loaded PROJ.4 runtime: Rel. 4.6.1, 21 August 2008
PROJ_LIB: /home/rsb/lib/r_libs/rgdal/proj
GRASS GIS interface loaded with GRASS version: 6.4.0svn
and location: nc_spm_08
Post by Markus Neteler
elev <- readRAST6("elev_state_500m")
may I suggest cosmetics:
raster map/current region mismatch detected in components:
?
Post by Roger Bivand
cols rows origin.northing origin.easting
FALSE FALSE FALSE FALSE
set plugin=TRUE to override; continuing with plugin=FALSE
/home/rsb/topics/grassdata/nc_spm_08/rsb/.tmp/reclus2/elev_state_500m has
GDAL driver GTiff
and has 620 rows and 1630 columns
Post by Markus Neteler
elev <- readRAST6("elev_state_500m", ignore.stderr=TRUE)
I've committed to sourceforge CVS, could you confirm that this is OK?
I'll do (tonight I won't manage and I got the mail only now due to
osgeo mail reflector stuck for some hours).
Hope tomorrow morning as first thing.
Post by Roger Bivand
How does one manage the plugin links in a mixed 6.4/7.0 setting? I tried 7.0
ERROR: Incompatible library version for module
which crashed R/rgdal. The plugin was built against 6.4RC1, so probably two
different library versions had a disagreement.
Oh, this is really a problem and needs to be discussed on grass-dev
or via trac ticket. Glynn had added this test which will cause troubles
here. Maybe there is a workaround possible.

Thanks for your efforts.

Best wishes,
Markus
Markus Neteler
2009-01-11 20:01:30 UTC
Permalink
...
Post by Markus Neteler
I'll do (tonight I won't manage and I got the mail only now due to
osgeo mail reflector stuck for some hours).
Hope tomorrow morning as first thing.
I managed to test and it went through well.
Post by Markus Neteler
Post by Roger Bivand
How does one manage the plugin links in a mixed 6.4/7.0 setting? I tried 7.0
ERROR: Incompatible library version for module
which crashed R/rgdal. The plugin was built against 6.4RC1, so probably two
different library versions had a disagreement.
Oh, this is really a problem and needs to be discussed on grass-dev
or via trac ticket. Glynn had added this test which will cause troubles
here. Maybe there is a workaround possible.
This remains open yet.

Thanks again,
Markus
Roger Bivand
2009-01-11 20:43:02 UTC
Permalink
Post by Markus Neteler
...
Post by Roger Bivand
Post by Markus Neteler
gdal/frmts/gtiff/geotiff.cpp: "SetColorTable() only
supportedfor Byte or UInt16 bands in TIFF format." );
if( eDataType != GDT_Byte && eDataType != GDT_UInt16 )
{
CPLError( CE_Failure, CPLE_NotSupported,
"SetColorTable() only supported for Byte or UInt16
bands in TIFF format." );
return CE_Failure;
}
I suppose there is some trick to suppress it (since it uses the
CPLError function).
I don't know too much about it but found
http://www.gdal.org/ogr/cpl__error_8h.html#ad2b98dd58e4de706a245faddac90403
Just throw stderr stuff to /dev/null (of course problematic with Windows)?
I've "handled" this for some definition of handle by setting -c in the
r.out.gdal call - this was controlling whether colour table writing was
attempted.
ah fine, I didn't think of this possibility.
Post by Roger Bivand
Post by Markus Neteler
Post by Roger Bivand
WARNING: Input raster map contains cells with NULL-value (no-data). The
value 999 was used to represent no-data values in the input map.
You can specify nodata value by nodata parameter.
...
Post by Roger Bivand
Post by Markus Neteler
http://trac.osgeo.org/grass/changeset/35321
It is in 6.4SVN and 7 SVN and will appear on Monday in 6.4.0RC2.
GRASS 6.3 and older are not affected as r.out.gdal wasn't there.
library(spgrass6)
Loading required package: sp
Loading required package: rgdal
Geospatial Data Abstraction Library extensions to R successfully loaded
Loaded GDAL runtime: GDAL 1.6.0, released 2008/12/04
GDAL_DATA: /home/rsb/lib/r_libs/rgdal/gdal
Loaded PROJ.4 runtime: Rel. 4.6.1, 21 August 2008
PROJ_LIB: /home/rsb/lib/r_libs/rgdal/proj
GRASS GIS interface loaded with GRASS version: 6.4.0svn
and location: nc_spm_08
Post by Markus Neteler
elev <- readRAST6("elev_state_500m")
?
Committed - so you'll see this when you get to it, thanks.

I'll worry about the 6.4 - 7.0 plugin issue when it becomes more pressing
for me - for now I'll avoid 7.0.

Best wishes,

Roger
Post by Markus Neteler
Post by Roger Bivand
cols rows origin.northing origin.easting
FALSE FALSE FALSE FALSE
set plugin=TRUE to override; continuing with plugin=FALSE
/home/rsb/topics/grassdata/nc_spm_08/rsb/.tmp/reclus2/elev_state_500m has
GDAL driver GTiff
and has 620 rows and 1630 columns
Post by Markus Neteler
elev <- readRAST6("elev_state_500m", ignore.stderr=TRUE)
I've committed to sourceforge CVS, could you confirm that this is OK?
I'll do (tonight I won't manage and I got the mail only now due to
osgeo mail reflector stuck for some hours).
Hope tomorrow morning as first thing.
Post by Roger Bivand
How does one manage the plugin links in a mixed 6.4/7.0 setting? I tried 7.0
ERROR: Incompatible library version for module
which crashed R/rgdal. The plugin was built against 6.4RC1, so probably two
different library versions had a disagreement.
Oh, this is really a problem and needs to be discussed on grass-dev
or via trac ticket. Glynn had added this test which will cause troubles
here. Maybe there is a workaround possible.
Thanks for your efforts.
Best wishes,
Markus
--
Roger Bivand
Economic Geography Section, Department of Economics, Norwegian School of
Economics and Business Administration, Helleveien 30, N-5045 Bergen,
Norway. voice: +47 55 95 93 55; fax +47 55 95 95 43
e-mail: ***@nhh.no
Roger Bivand
2009-01-13 09:23:14 UTC
Permalink
The changes to handle finding files in other mapsets and to remove
confusing messages have been included in spgrass6_0.5-17, now released on
CRAN. It checks cleanly against 6.4.0svn, Revision: 35395, so RC2 is good
too (this is the svn up number, but the number in Help -> "About GRASS
GIS" in the wxpython GUI is lower - any way to harmonise?).

Roger
Post by Roger Bivand
Post by Markus Neteler
...
Post by Roger Bivand
Post by Markus Neteler
gdal/frmts/gtiff/geotiff.cpp: "SetColorTable() only
supportedfor Byte or UInt16 bands in TIFF format." );
if( eDataType != GDT_Byte && eDataType != GDT_UInt16 )
{
CPLError( CE_Failure, CPLE_NotSupported,
"SetColorTable() only supported for Byte or UInt16
bands in TIFF format." );
return CE_Failure;
}
I suppose there is some trick to suppress it (since it uses the
CPLError function).
I don't know too much about it but found
http://www.gdal.org/ogr/cpl__error_8h.html#ad2b98dd58e4de706a245faddac90403
Just throw stderr stuff to /dev/null (of course problematic with Windows)?
I've "handled" this for some definition of handle by setting -c in the
r.out.gdal call - this was controlling whether colour table writing was
attempted.
ah fine, I didn't think of this possibility.
Post by Roger Bivand
Post by Markus Neteler
Post by Roger Bivand
WARNING: Input raster map contains cells with NULL-value (no-data). The
value 999 was used to represent no-data values in the input map.
You can specify nodata value by nodata parameter.
...
Post by Roger Bivand
Post by Markus Neteler
http://trac.osgeo.org/grass/changeset/35321
It is in 6.4SVN and 7 SVN and will appear on Monday in 6.4.0RC2.
GRASS 6.3 and older are not affected as r.out.gdal wasn't there.
library(spgrass6)
Loading required package: sp
Loading required package: rgdal
Geospatial Data Abstraction Library extensions to R successfully loaded
Loaded GDAL runtime: GDAL 1.6.0, released 2008/12/04
GDAL_DATA: /home/rsb/lib/r_libs/rgdal/gdal
Loaded PROJ.4 runtime: Rel. 4.6.1, 21 August 2008
PROJ_LIB: /home/rsb/lib/r_libs/rgdal/proj
GRASS GIS interface loaded with GRASS version: 6.4.0svn
and location: nc_spm_08
Post by Markus Neteler
elev <- readRAST6("elev_state_500m")
?
Committed - so you'll see this when you get to it, thanks.
I'll worry about the 6.4 - 7.0 plugin issue when it becomes more pressing for
me - for now I'll avoid 7.0.
Best wishes,
Roger
Post by Markus Neteler
Post by Roger Bivand
cols rows origin.northing origin.easting
FALSE FALSE FALSE FALSE
set plugin=TRUE to override; continuing with plugin=FALSE
/home/rsb/topics/grassdata/nc_spm_08/rsb/.tmp/reclus2/elev_state_500m has
GDAL driver GTiff
and has 620 rows and 1630 columns
Post by Markus Neteler
elev <- readRAST6("elev_state_500m", ignore.stderr=TRUE)
I've committed to sourceforge CVS, could you confirm that this is OK?
I'll do (tonight I won't manage and I got the mail only now due to
osgeo mail reflector stuck for some hours).
Hope tomorrow morning as first thing.
Post by Roger Bivand
How does one manage the plugin links in a mixed 6.4/7.0 setting? I tried 7.0
ERROR: Incompatible library version for module
which crashed R/rgdal. The plugin was built against 6.4RC1, so probably two
different library versions had a disagreement.
Oh, this is really a problem and needs to be discussed on grass-dev
or via trac ticket. Glynn had added this test which will cause troubles
here. Maybe there is a workaround possible.
Thanks for your efforts.
Best wishes,
Markus
--
Roger Bivand
Economic Geography Section, Department of Economics, Norwegian School of
Economics and Business Administration, Helleveien 30, N-5045 Bergen,
Norway. voice: +47 55 95 93 55; fax +47 55 95 95 43
e-mail: ***@nhh.no
Loading...